Time not displayed on weather page

Any discussion related to FSiPanel 2017
Post Reply
LecLightning56
Posts: 80
Joined: Sat Jan 06, 2018 6:26 am

Time not displayed on weather page

Post by LecLightning56 » Tue Dec 25, 2018 5:30 pm

The time and date section of the weather page is populated by two date options with no time option displayed. I am using Version 1.0.0.50 of FSiPanel.
Is this a bug or do I have some settings incorrectly configured? The image below shows my FSiPanel window.

Image

I have tried the installation in Windows 7 where the problem does not exist but it does seem to be Windows 10-related. Could it be anything to do with fonts?
Last edited by LecLightning56 on Sun Jan 06, 2019 5:51 pm, edited 2 times in total.

jpgarraio
Site Admin
Posts: 347
Joined: Fri Sep 15, 2017 10:30 am

Re: Time not displayed on weather page

Post by jpgarraio » Fri Dec 28, 2018 3:18 pm

Hi,

It seems to be related to your date and time format settings.

Interesting but though, could you post a screenshot of your date time regional settings?

Cheers,

J-P

LecLightning56
Posts: 80
Joined: Sat Jan 06, 2018 6:26 am

Re: Time not displayed on weather page

Post by LecLightning56 » Fri Dec 28, 2018 8:37 pm

J-P,

Did a complete reinstall of the Microsoft SQL Server Express 2012 LocalDB from the installation files and normality has now been restored!

Problem now solved.

wsjcdp
Posts: 2
Joined: Wed Jan 02, 2019 3:18 pm

Re: Time not displayed on weather page (Solved)

Post by wsjcdp » Sat Jan 05, 2019 5:01 pm

I have the same problem, however, unable to solve by reinstalling SqlLocalDB64.MSI. Please help.

jpgarraio
Site Admin
Posts: 347
Joined: Fri Sep 15, 2017 10:30 am

Re: Time not displayed on weather page (Solved)

Post by jpgarraio » Sat Jan 05, 2019 5:59 pm

I will check that issue and come back to you.
Could you tell me what regional setting you have for your date and time?
Cheers,

J-P

jpgarraio
Site Admin
Posts: 347
Joined: Fri Sep 15, 2017 10:30 am

Re: Time not displayed on weather page (Solved)

Post by jpgarraio » Sat Jan 05, 2019 6:40 pm

Please download and try the BETA version of FSiPanel 2017 for P3D.
The link is on top of the forum under BETA.

Cheers,

J-P

wsjcdp
Posts: 2
Joined: Wed Jan 02, 2019 3:18 pm

Re: Time not displayed on weather page (Solved)

Post by wsjcdp » Sun Jan 06, 2019 2:10 pm

Downloaded and installed V 1.0.0.50B. Appears to be working as advertised. Attached are my region settings.

Appreciated your support.

Regards,
You do not have the required permissions to view the files attached to this post.

LecLightning56
Posts: 80
Joined: Sat Jan 06, 2018 6:26 am

Re: Time not displayed on weather page (Solved)

Post by LecLightning56 » Sun Jan 06, 2019 5:43 pm

J-P,

Applied the latest beta update as advised but what I am getting is a shown below:

Image

The time is shown but the font size is small for those of us more myopic with years and strangely, a calendar selection appears on the right of the time displayed which does not seem to have any purpose for displaying the time itself.

If you can restore the date and time inputs to their formal glory in larger fonts and boxes, so much the better!

Hope you can have a look and revise things accordingly. I am now not so sure that reinstalling the SQL Server LocalDB has any effect whatsoever.

LecLightning56
Posts: 80
Joined: Sat Jan 06, 2018 6:26 am

Re: Time not displayed on weather page

Post by LecLightning56 » Sun Jan 06, 2019 5:54 pm

This is even more strange. if I start up Prepar3D v4 then run FSiPanel and select Weather, the following screen is displayed:

Image

This is the correct? format I presume but the point being that it is prompted into displaying things this way by Prepar3D v4.

Hope this additional information helps to resolve this issue. Note that in the image above this there are no arrow keys to incrementally change the time higher or lower.
Last edited by LecLightning56 on Sun Jan 06, 2019 11:34 pm, edited 1 time in total.

LecLightning56
Posts: 80
Joined: Sat Jan 06, 2018 6:26 am

Re: Time not displayed on weather page

Post by LecLightning56 » Sun Jan 06, 2019 9:43 pm

I have just changed the Scale and Layout settings under Display in Windows 10, changing to 125% and then back to 100% and the Time and Date boxes in FSiPanel are now how they should be. A quick and easy fix which could be the result of a glitch in Windows 10.

This could be a text size issue, more particularly in Windows 10.

Post Reply